Knowledgebase
Java 9 and Java 10 compatibility | How to make JSCAPE MFT Server run on Java 9 or Java 10
Posted by John Villanueva on 26 July 2018 06:22 PM

As of this writing, current versions of MFT Server (as well as other JSCAPE products like MFT Gateway, MFT Monitor, MFT Synchronizer, etc) are not yet readily compatible with Java 9 or Java 10 upon installation. 

However, with just a few tweaks you can let these applications run on Java 9 or 10. 

Basically, you just need to add the following lines to the application's corresponding '.vmoptions' file (e.g. server.vmoptions, gateway.vmoptions etc.):

--add-modules=java.activation
--add-modules=java.xml.bind


After that, restart the application service.

All GUI installers automatically add these lines if JDK 9 or higher is detected. But for the '.zip', '.rpm' and '.tar.gz' versions, the user should make necessary changes manually.

Note that this options work under JDK 9/10 (as well as JRE 9/10) only. For lower versions of JDK they should be removed. Otherwise, the application won't start.

Note also that Java SE 9 has reached end of support. Oracle recommends that users of Java SE 9 should switch to Java SE 10.

(0 vote(s))
This article was helpful
This article was not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments:
CAPTCHA Verification 
 
Please enter the text you see in the image into the textbox below. This is required to prevent automated registrations and form submissions.

Help Desk Software by Kayako fusion